رفع خطای “کوپن باید با یک محصول فروشنده محدود شود” در وردپرس

9 ماه قبل
پدرام قلی زاده

سلام دوستان وقتتون بخیر

اگر از قالب های آماده بسیار استفاده میکنید و یا از افزونه دکان Dokan برای چندفروشندگی ووکامرس استفاده میکنید ، گاهی ممکن است با خطای زیر روبرو شوید :

کوپن باید با یک محصول فروشنده محدود شود

 

 

رفع این خطا در وردپرس بسیار ساده است. برای  رفع این مشکل ، کافیست قطعه کد زیر را در افزونه دکان لایت Dokan-lite جستجو کرده و حذف کنید.

'woocommerce_coupon_is_valid', array( $this,'ensure_vendor_coupon'), 10, 3 );

 

 

برای اینکار ، دو راه پیش روی شماست :

 

  • راه حل اول : استفاده از افزونه String Locator

ابتدا افزونه String Locator را از مخزن وردپرس دانلود کنید. سپس عبارت woocommerce_coupon_is_valid را در میان فایل‌های افزونه دکان لایت جستجو کنید. در پوشه include یک فایل حاوی این قطعه را مشاهده خواهید کرد. کافیست کد را کامنت کنید. (آموزش کامنت کردن کد PHP)

 

 

  • راه حل دوم : جستجوی دستی

در این روش خبری از نصب افزونه برای جستجو نیست ؛ باید میان فایلهای افزونه dokan-lite به دنبال قطعه کد بالا بگردید و آنرا کامنت کنید. بهتر است از روش اول استفاده کنید/

 

 

اگر مشکلی داشتید ، در کامنت از ما بپرسید/

 

نظر شما چیست؟

ثبت نظر